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Group Size 

� 3 or 4. Due date : at  next week labs. 

 

Requirements 

� Using MS Access, implement an application for a students project groups and teachers. 

 

What should be covered: 

� Opening a Database 
� The Database Window  

� Opening a Database, Viewing Data and Closing a Database 

� Getting Help using Microsoft Access  

� Creating a New MS-Access Database (create tables, Plan Fields and Data Types, Set Field 

Properties, Set a primary key for a table). 

� Add and Save Records. 

� Delete, Insert, and Rearrange Fields in a Table. 

� Create a Field that Looks up or Lists Values in Tables 

� Setting Table Properties 

� Creating Relationships between Tables 

� Viewing and Editing Existing Relationships 

� Relationship Types 

� Referential Integrity 

� Cascading Delete and Update Operations 

 

Problem Description:  

Assume that you are responsible about arrange students projects. Create a database to manage all 

the data required to run the project system . Assume you have tables names like  : 

Student ( fields …..) 

Groups ( fields….) 

Teachers(fields…) 

Student status (fields….) 

. 

. 

 

Creating a New MS-Access Database 
 

When you create a Microsoft Access database, you create one file that contains all the tables in your 

database as well as the queries, forms, reports and other objects that help you use the information in 

the database. 

 

Microsoft Access provides two methods to create a database. You can create a blank database and 

then add the tables, forms, reports and other objects later and this is the most flexible method, but it 

requires you to define each database element separately. Or you can use a Database Wizard to create 

in one operation the required tables, forms and reports for the type of database you choose and this is 

the easiest way to start creating your database. Either way, you can modify and extend your database 

at any time after it has been created. 
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In the following sections, we describe how to create a database using a Database Wizard and then how 

to create a blank database. 

 

Create a New Database 
 

Use a Template to create a new Database 

 

1. In the Microsoft Access startup window, choose New from the File menu. 

 

2. The New dialog box is displayed on the right of the screen. Choose the General Template option 

to list the range of template databases (as in the following figures) that you can create with the 

Database Wizard. To select the database you need, double-click the icon. The wizard will create 

what you need to store, enter and summarise your data. Once you have selected the template for 

your database, the wizard leads you through a series of design steps.  
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To create a database (without Database Wizard) 
1.  In the Microsoft Access startup window, choose New from the File menu. Or click the New button 

on the toolbar.       

  
  

Microsoft Access displays the New dialog box. The General option displays the File New dialog 

box that allows you to create a database from scratch and gives your new database a default name 

(e.g. db1), which you can replace with the name of your choice.  

 

2. In the File name box, type the name of your database. A database name can contain up to 64 

characters. Microsoft Access automatically appends a mdb extension to your database filename. 

 

3. To store the database in a different directory or drive, select the location of the file you want in the 

Save in list.  

 

4. Choose Create. Microsoft Access creates an empty database file and opens the Database window. 

 

Activity 
Create a new blank database called HomeVideo_Yourname.mdb (use the initial letters of all the group 

members in the database name, example Nada,Huda and Muna�HomeVideo_NHM)and save it to 

your folder. This database will hold the tables, forms, reports and other objects for a video rental shop. 

 

Create a Table 

 
Microsoft Access provides three ways to create a blank (empty) table: 

 

• Use the Database Wizard to create in one operation all the tables, forms and reports required for 

an entire database.  

• Use Design view to specify all of your table details from scratch. Use the Table Wizard to choose 

the fields for your table from a variety of predefined tables such as business contacts, household 

inventory or medical records. 
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• Enter data directly into a blank datasheet. When you save the new datasheet, Microsoft Access 

will analyse your data and automatically assign the appropriate data type and format for each field. 

 

Regardless of which method you use to create a table, you can use table Design view at any time to 

customise your table further, such as adding new fields, setting default values or creating input masks. 

 

In the following sections we will describe in more detail the process of creating a table using a Table 

Wizard and then how to create a table using design view. 

 
To create a table using the Table Wizard 

 

1.  Start Microsoft Access, and open the database that is to contain the table. 

 

2.  In the Database window, click the Tables button, and then choose the New button.  Or select the 

Insert menu and choose Table. Microsoft Access displays the New Table dialog box, as shown in 

Figure 3. 

 

 

 
Figure 3: New Table dialog box. 

 

3.  Choose the Table Wizard option. 
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4. You are then prompted to make appropriate choices as you create your table using the Table 

Wizard. To display the next Table Wizard dialog box, choose the Next button. The final dialog box 

offers you the options to further modify your table, add rows to the table, create a form based on 

your table using the Table Wizard or finish. 

 

To create a table using Design view 

 
1. In the Database window, click the Tables button and choose the New button (or choose Table 

from the Insert menu). 

 

2. The New Table dialog box is displayed (as shown in Figure P1-3).  

 

3. Choose the Design View button to open a blank Table window in Design view, as shown in 

Figure 4. Type and table field name and choose the appropriate data type from the ‘Data Type’ 

drop-down box.  

 

 
Figure 4:  Table Design view. 

 

Plan Fields and Data Types 

 

The Field Name identifies the data stored in a field.  A field name can contain up to 64 characters, 

including spaces. The Data Type tells Microsoft Access what kind of data goes in the field, such as 

text, numbers, dates or currency.  

 

A brief description of the most commonly used data types is given below: 

 

The Text data type is used for words (such as names), for combinations of words and numbers (such 

as addresses), and for numbers that are not used in mathematical calculations (such as telephone 

numbers). 

The AutoNumber data type stores sequential numbers created by Microsoft Access.   
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The Date/Time data type is used for dates and times.  

The Number data type is used for numbers that can be used in mathematical calculations, and also for 

fields that are related to other Number fields or to AutoNumber fields.  

The Currency data type is used for currency values such as francs, dollars, or yen.  

The Yes/No data type is used for yes or no, true or false values. 

The Memo data type is used to store long textual descriptions up to a maximum size of 64,000 

characters. Memo fields cannot be indexed.  

The Lookup Wizard use to create a field that allows you to choose a value from another table or from 

a list of values using a combo box—-choosing this option in the data type list starts a wizard to define 

this for you.  

 

 

More Information For details about data types, click in the Data Type column and press F1. 

 

Add Fields to the Table 

 

To add a field 

 

1.  Type the name of the field to be added in the first empty box under Field Name. 

 

2.  Press TAB to move to the Data Type box. Microsoft Access gives the field a Text data type.  

However, if the field is not text, you’ll need to select the appropriate data type. 

 

3.  To open the list of alternative data types, click the arrow or press ALT+ DOWN ARROW. 

 

4. Press TAB to move to the Description box. If required, you may enter in a short description for 

each field to help you remember the purpose of the field. 

 

Set Field Properties 

 

Each field in a table has a set of properties.  By changing a field's properties, you can control how 

Microsoft Access stores, handles, and displays data in a field.  For example, you might want your data 

displayed in a particular format - numbers in scientific notation, perhaps, or dates with the month's 

name abbreviated. The Format property controls how data is displayed in datasheets, forms, and 

reports. 

 

To set a field property 

 

1.  Click any box in the row that defines the field to be set. 

 

2.  Click the box of the required property, and then set or select the appropriate property setting. 

 

Field Size: The size and type of numbers to enter in the field. For example, if the Data type of selected 

Field has been selected as ‘Number’, the field size can be set as ‘Long integer’ as the 

common choice. If the Date type of selected field is ‘Text’, the value of field size stands 

for the maximum number of characters you can enter in the field. The largest maximum 

you can set for the ‘Text’ data type is 255. Note!! If you need to store more than 255 

characters, a ‘Memo’ field can store up to 65,536 characters. If you want to store 

formatted text or long documents, you should create an OLE object field instead of a 

Memo field. 

Format:    The display layout for the field. Select a pre-defined format or enter a custom format.  
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Decimal Places: The number of digits that are displayed to the right of the decimal separator. 

Input Mask: 

Caption: provided a customized label for the field when used on a form. If you don’t enter a caption, 

the field name is used as the label.  

Default Value: A value that is automatically entered in this field each time when creating a   new 

record in the table. 

Validation Rule: An expression that limits the values that can be entered in the field.  

Validate Text:  The error message that appears when you enter a value prohibited by the validation 

rule.  

Required: Required data entry in this field. This property can be associated with ‘Allow Zero length’ 

together to make sure the data entry for the selected field is ‘not null’, especially useful for 

the primary key. 

Allow Zero length:  

Indexed: An index speeds up searches and sorting on the field, but may slow updates. Selecting “Yes 

– No Duplicates” prohibits duplicate values in the field.  

 

To delete a property setting 

 

Select the setting for the property of the field, and then press the Delete key 

 

More information For more information about an individual field property, click the property and 

press F1. 

 

To set a primary key for a table 
 

Open the table in Design View and select the appropriate row(s) that form the primary key for the 

table. Then select the Primary Key button on the toolbar. 

 
A key icon will appear in the column to the left-hand side of the field or fields selected to be the 

primary key. You can also set a primary key by selecting the Edit menu and then choosing Primary 

Key. 

  

To save a table 

1.  From the File menu, choose Save (or click the Save button on the toolbar).   

  

2.  If you are saving the table for the first time, type a name for the table and choose OK. 

 

To modify the design of an object 

 

1.  In the Database window, click the button for the type of object (e.g. Tables, Forms) that you want 

to modify. 

 

2.  In the list that is displayed, select the object you want to modify. 

 

Choose the Design button. Microsoft Access opens a window for the object and displays it in Design 

view. 

 

Activity 
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In this practical you will create four tables for the HomeVideo_Yourname database using Design view. 

The tables are Member to hold members details, Video to hold details of videos, VideoForRent to 

hold the details of copies of videos for rent, and RentalAgreement to hold the details of video rentals 

by members. 

 

The Member table has the following fields (with the data type of each in brackets): 

memberNo (AutoNumber), fName (Text), lName (Text), sex (Text), DOB (Date/Time), address 

(Text), dateJoined (Date/Time), comments (Memo) 

The primary key is memberNo 
(Also for this table, set the format property of the Sex field to a field size of 1 with an Input Mask >L. 

[You have to explain what this Input Mask means??] 

Also, set this field with a Validation Rule =”M” or “F” and Validation Text Please enter M or F. If 

you do not understand the purpose of the properties associated with each field, remember to use the 

help facility using the F1 key). 

 

The Video table has the following fields (with the data type of each in brackets): 

catalogNo (Text), title (Text), certificate  (Text), category (Text), dailyRental (Currency), price 

(Currency), directorNo (Text) 

The primary key is catalogNo 
 
The VideoForRent table has the following fields (with the data type of each in brackets): 

videoNo (Text), available (Yes/No), catalogNo (Text) 

The primary key is videoNo 
 

The RentalAgreement table has the following fields (with the data type of each in brackets): 

rentalNo (AutoNumber), dateOut (Date/Time), dateReturn (Date/Time), memberNo (Text), 

videoNo(Text) 

The primary key is rentalNo 

(Also for this table, set the format property for the dateOut and dateReturn fields to Medium Date 

format e.g. 10-Oct-00. If you do not understand the purpose of the properties associated with this 

field, remember to use the help facility using the F1 key). 

 
Add and Save Records 

 
Each table in your database has two views: Design view and Datasheet view. You add records to the 

Datasheet view. 

 

To switch to Datasheet view 

From the View menu, choose Datasheet or click on the Datasheet button. The  

arrow to the right of the button lists the alternative views of the table. 

 

To add a record of data 
 

Type in the data values and press TAB to the next field. 

  

To save a record of data 

 

Once you have entered all of the required records, press TAB to move to the first empty field below 

these records. 
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You do not require to do anything else to save your data. When you leave a record, either by moving 

to another record or by closing a table, Microsoft access automatically saves the data. 

 

Edit Records and Close a Table 
 
To edit records 

 

There are various ways to edit records. For example: 

 
To move to the next or the previous field, press TAB or SHIFT+TAB, respectively. 

To select or deselect the current field, press F2. 

To undo changes to the current field or record, press ESC. 

To replace the value in a field with the value of the same field in the previous record, press CTRL+’ . 

 
To close a table 

 

From the File menu, choose Close. 

 

 

Activity 
Add the records below into your Member, Video, VideoForRent and RentalAgreement. The 

VideoForRent table should hold details of copies of videos described in your Video table and the 

RentalAgreement table should record the members described in your Member Table renting copies 

of videos described in your VideoForRent table.   

 

Reopen your tables and practise editing your records. Finally, save and close your table and exit from 

the HomeVideo_Yourname database.  

 

 
Member 

memberNo fName lName sex DOB address dateJoined 

1 Karen Parker F 22- 1972-���ا��  22 Greenway Drive, Glasgow, G12 8DS 06- �����-1991  

2 Gillian Peters F 09- 1954- ��رس  89 Redmond Road, Glasgow, G11 9YR 19- 1995-ا����  

3 Bob Adams M 15- ������-1974  57 Littleway Road, Glasgow, G3 6DS 06- �����-1998  

4 Don Nelson M 12- 1951-د�����  123 Suffolk Lane,Glasgow, G15 1RC 07- 2000-ا����  

5 Lorna Smith F 01- �����-1972  Flat 5A London Road, Glasgow, G3 11- �����-1998  

6 Dan White M 05- ����-1960  200 Great Western Road, Glasgow, G11 9JJ 05- ����-2001  

7       

 

Video 
catalogNo Title certificate category dailyRental price directorNo 

207132 Tomorrow Never Dies 12 Action £5.00 £21.99 D1001 

330553 Face/Off 12 Thriller £5.00 £31.99 D4576 

445624 The Rock 18 Action £4.00 £29.99 D5743 

634817 Independence Day PG Sci-Fi £4.50 £32.99 D3765 

781132 101 Dalmatians U Children £4.00 £18.50 D0078 

902355 Primary Colors U Comedy £4.50 £14.50 D7834 
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RentalAgreement 

rentalNo memberNo videoNo dateOut dateReturn 

1 1 178643 05- 2000-���ا��  07- 2000-���ا��  

2 1 199004 05- 2000-���ا��  07- 2000-���ا��  

3 1 245456 04- 2000-���ا��  06- 2000-���ا��  

4 1 243431 04- 2000-���ا��  06- 2000-���ا��  

5 3 199004 11- ������-1999  12- ������-1999  

6 2 245456 11- ������-1999  13- ������-1999  

7 4 178643 14- ������-1999  16- ������-1999  

8 3 243431 11- ������-1999  13- ������-1999  

9 1 245457 12- ������-1999  14- ������-1999  

10 3 199004 10- ��2000- ا��   

11 2 199004 17- ��2000- ا��  20- ��2000- ا��  

 

VideoForRent 
videoNo Available catalogNo 

178643 No 634817 

199004 Yes 207132 

200900 Yes 330553 

210087 Yes 902355 

243431 Yes 634817 

245456 Yes 207132 

245457 Yes 207132 

317411 Yes 781132 

 

Delete, Insert, and Rearrange Fields in a Table 
 

In a table's Design view, you can easily review and edit all the fields in the table.  You can delete fields 

or insert new fields wherever you want them.  You can also rearrange fields to whatever order you want.  

Rearranging the fields in Design view rearranges the order of columns, or fields, in Datasheet view. 

 

Use the View    and   buttons on the toolbar to switch between Design view and Datasheet 

view. 

 

To rearrange fields 

 

1.  Open the table in Design view and then select the row to be rearranged by clicking its row selector. 

The row selector is the first column (shaded) on the left-hand side of the table . 

 

2.  Click the row selector again, hold the mouse button down, and then drag the row to the required 

position in the table. 

 

3.  When the pointer is where you want the row placed, release the mouse button. Microsoft Access 

moves the field. 

 

To delete a field 
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1.  Open the table in Design view. 

 

2.  Select the row that defines the field you want to delete by clicking its row selector. From the Edit 

menu, choose Delete or Delete Rows. (Alternatively, you can press the Delete Rows button on the 

toolbar).  

 
2.  Microsoft Access deletes the field and all its data from your table.  
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To insert a new field above an existing field 

 

1. Click the row above which you want the new row to appear. 

2.  From the Insert menu, choose Rows (or press the Insert Rows button    on the toolbar). 

Microsoft Access inserts an empty row above the current row. 

 

3.  Define your new field in the empty row. 

 

Activity  
Restructure the Member table by deleting the comments field.  

 

Create a Field that Looks up or Lists Values in Tables 

 
Using the Lookup Wizard, you can create a field that displays either of two kinds of lists to make data 

entry simpler: 

 

• A lookup lists that displays values looked up from an existing table or query. 

• A value list that displays a fixed set of values that you enter when you create the field. 

 

The Lookup Wizard gives you the option to display the list as a combo box or a list box. The difference 

between these two types of boxes is in the way that the list of values is displayed to the user and whether 

it is possible to allow the user to add to the list of values. If you use the list from a table or query’s 

datasheet, the list can only be displayed as a combo box.  

 

The most common type of lookup list displays values looked up from a related table. For example, the 

SupplierID field in the Products table of the Northwind sample database. This list is created by looking 

up the SupplierID values in the Supplier table and displaying the corresponding Supplier names. Picking 

a value from a Lookup list sets the foreign key value in the current record (SupplierID in the Products 

table) to the primary key value of the corresponding record in the related table (SupplierID in the 

Supplier table). 

 

A value list looks the same as a lookup list, but consists of a fixed set of values you type in when you 

create it. A value list should only be used for values that will not  change very often and don’t need to be 

stored in a table. For example, a list for a Salutation field may contain the following values, Mr, Mrs and  

Ms. 

 

You can add a new lookup or value list field to a table in either design view or datasheet view. However, 

if the field you want to use as the foreign key for a Lookup table already exists, you must open that 

field’s table in design view to define the Lookup field. 

 

To create a field that looks up and displays data from another table or a value list in design view 

 
1.  Open the table in Design view. 

 

2.  Insert the new field or if the field you want to use already exist, click in that field’s row. 

 

3.  In the data type column, select Lookup Wizard. 
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4.  To display data from another table; select option (1) I want the lookup column to look up values in a 

table or query .To display data from a value list; select option (2) I will type in the values that I want. 

 

5.  Click Next and follow the instructions in the remaining Lookup Wizard dialog boxes. 

 

To create a field in datasheet view that looks up and displays data from another table or value list 

 

1. In Datasheet view, click on the column to the right of where you want to insert the field, and then on 

the Insert menu, click Lookup Column.  

 

2.  In the first dialog box described in part 4 above, select the option that indicates your choice. 

 

3.  Click Next and follow the instructions in the remaining Lookup Wizard dialog boxes. 

 

Activity 
Convert the certification (e.g. U, PG, 12, 15, 18) field of the Video table into a Lookup field that uses 

a value list, as shown in Figure 5.  

 

 

 
 

Figure 5:  Value list for certification field of Video table. 
 

Activity 
Convert the directorNo field of the Video table into a Lookup field that displays data from another 

table, as shown in Figure 6. To start this activity it is necessary for you to first create a table called 

Director that will hold the details of directors.  

 

The Director table has the following fields (with the data type of each in brackets): 

directorNo (Text), directorName (text) 

The primary key is directorNo 

 

When converting the directorNo field to a Lookup field select the option that hides the key column 

(directorNo) and only display the directorName field in the Video table. 

 

Hint: Read about Row Source Type, Row Source, Bound Column, Column Count, and Column 

Widths in the help. Don’t forget to add two fields in the lookup Row Source (directorNo, 
directorName), Check if the Column widths set to 0 for a field column? 

 

Director 
directorNo directorName 
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Director 
directorNo directorName 

D0078 Stephen Herek 

D1001 Roger Spottiswoode 

D3765 Jane Emmerick 

D4576 John Woo 

D5743 Michael Bay 

D7834 Sally Nichols 

  

 
 

Figure 6:  The directorNo field of the Video table displaying data from the Director table. 
 

Resize Columns and Rows and Move Columns in a Datasheet 
 

In Datasheet  view,  you can resize columns and rows and move columns to fit your immediate needs, 

similar to the way you can edit a spreadsheet.  In addition, you can save your layout so that Microsoft 

Access always displays the datasheet the way you want it.  

 

To resize a column to fit the data it contains 

 

1.  Open the table in Datasheet view. 

 

2. Double-click an edge of the fields selector (column heading) of the column. Microsoft Access resizes 

the column to fit the data. 

 

To resize rows in a datasheet 

 

1. Position the pointer on the border of any record selector. The pointer changed to ×   to show that the 

border can be moved up or down. 

 

2. Drag the border down to make all the rows taller.  Drag it up to make all the rows narrower. 

 

3. When the row is the size you want, release the mouse button.  Microsoft Access resizes all the rows. 

 

To reorder columns 

 

1. Position the pointer on the field selector (column heading) of the column to be reordered. The pointer 

changes to ↓ to show that you can select the column. 

 

2. Click the field selector to select the column. 
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3. Click the field selector again, hold the mouse button down, and drag the column to the left or right, 

over the other column(s). 

 

4. When the pointer is where you want the column placed, release the mouse button. Microsoft Access 

reorders the columns. 

 

To save your datasheet layout 

 

On closing the datasheet window you can choose whether you wish to save the current layout of the 

datasheet.  

 

Activity 
View any of your tables in Datasheet form and practise editing the layout by resizing columns and 

rows, and by reordering the columns. Do not save your rearranged datasheet. 

 

Print, Minimize, Restore, and Close a Table 
 

You use the same techniques to print, minimize, restore, and  close a table that you use in any standard 

application for Windows.  Use these techniques for any Microsoft Access object. 

 

To print a table 

 

With the table open in datasheet view, choose Print from the File menu (or click the Print button on the 

toolbar) and then choose OK. 

               
To minimize a table 

 

Click the Minimize button    in the upper-right corner of the table window. Microsoft Access 

minimizes the table to an icon and places the icon at the bottom of the Microsoft Access window. This 

moves a table out of the way without closing it. 

 

To restore a table 

 

Double-click the table icon in the Microsoft Access window. 

 

To close a table 

 

From the File menu, choose Close. If you've made changes to the table design or layout since last saving 

it, Microsoft Access prompts you to save the changes.   

 

Activity 
Print the datasheet for your Video table.  Practise, minimising, restoring and closing your tables. 

 

Import Data into MS-Access 
 

To import a spreadsheet into MS-Access 

 

1. Open the Access database you created in the last week.  
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• Switch to the Database window 

 

2. Choose the ‘File |Get External Data’ 

• Choose ‘Import’ from the submenu 

 

3. Select the spreadsheet file for importing data 

•  Select type of spreadsheet from ‘Files of Type’ drop-down list; 

 
  

• Select the spreadsheet file via windows resource browser 

The sample of MS-Excel has been created and saved in the following path: 

“L:\cmpcp0015\Resources\MemberNo.xls”.  

 

 
      

 This ‘MemberNo.xls’ MS-Excel file contains some sample data with the same columns / 

fields as the table you created in the last week.  
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4. Click the ‘Import‘ button, then you will go to the window as the following 

 
 

After you select a worksheet or a named range (in this case, stick with the show worksheets), choose 

the worksheet you want to import the data. As the ‘MemberNo.xls’ only has ‘Sheet1’ with sample 

data, so please select the ‘sheet1’. Click Next to go the next window. 

 

 
 

Select the Firs t row Contains Column Heading check box as the column heading has already been 

created in the ‘sheet1’. Access will automatically convert the column heading in MS-Excel into the 

fields / columns in the target table. After importing data into MS-Access, you can remove that column 
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heading from the worksheet for keeping the consistence of original file. Click Next to go to the next 

step. 

 

 
In the window that appears above, you can specify whether you want to import the data to a new table 

or append it to an existing one in the MS-Access. In this test, select ‘In a New Table’. Click Next to 

go the next window.  

 

 
 

If you have chosen to create a new table, you can scroll left and right to the various fields and tell the 

wizard fields should be indexed in the new table. Your indexing choices are identical to the ones 

you’ll find for the Indexed property of a table field in Design View. In this test, for the MemberNo 

field, select Yes (No Duplicates) from the ‘Indexed’ drop-down list box, shown in the following 

Figure.  
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Note: As the ‘MemberNo’ field will be chosen as the primary key in the next stage, we select ‘Yes 

(No Duplicates)’ for the ‘Indexed propety’ as the value of primary key can’t be duplicated. 

 

As you can move from field to field, the Data Type combo box displays the data type that the wizard 

picks for each field. Click ‘Next’ to the next window. 

 

 
 

In the window above, you can designate a field as the primary key for the new table. If you want, you 

can tell the wizard to build an ID field for you that will use the AutoNumber data type by ticking the 

‘Let Access add primary key’. As the ‘MemberNo’ has already been chosen as the primary key, we 

tick the option ‘Choose my own primary key’ and select the ‘MemberNo’ from the list.  

 

If multiple fields form a unique value as the composite primary key, you can tell the wizard not to 

create a primary key at this stage. Later, you can open the resulting table in the Design view to set the 

primary key manually.  

 

Click Next to go to the final window of the wizard. 
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In this window, you can change the name of your new table. (The wizard chooses the name of the 

spreadsheet or the name range you picked in the previous step).  

 

Click Finish in the last window to import your data. Access opens a message box that indicates the 

result of the import procedure. If the procedure is successful, the new table will have the name you 

entered in the last step. If you asked to append the data to an existing table and Access found errors. 

You can choose to complete the import with errors or go back to the wizard to attempt to fix the 

problem. You might need to exit the wizard and correct data in the original spreadsheet file. 

 

Setting Table Properties 

In addition to field properties, you can set properties that apply to an entire table and to entire records.  

You set these properties in the table's property sheet.  The list shown below gives the table properties 

and their uses.  

 

Table Property       Uses 

 
Description Store a description of a table's contents and purpose.  For attached tables, 

Microsoft Access stores a description of the table's source. 

Validation Rule Limit data entered in a record to values that meet certain requirements.  Microsoft 

Access checks to make sure the data follows this rule before it saves a record in 

the table. 

Validation Text Display a message when the record validation rule is violated. 

Filter Store a description of the filter for the table. 

Order By Store a description of the sort order for the records of the table. 

Subdatasheet Name  Specify the table or query (subdatasheet) that is bound to the table. A subdatasheet 

is a datasheet that is nested within another datasheet that contains data related or 

joined to the first datasheet. 

LinkChildFields / LinkMasterFields  Specify how Microsoft Access links records in the table to the subdatasheet.  If 

set, Microsoft Access automatically updates the related record in subdatasheet 

when you change to a new record in a table. 

Subdatasheet Height Specify the display height of a subdatasheet when expanded. 

Subdatasheet Expanded Specify the saved state of all subdatasheets within a table. 

 

To set a table property 
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1.  Open the table in Design view. 

 

2.  From the View menu, choose Properties (or click the Properties button on the toolbar).  

 

           
 

Microsoft Access displays the table's property sheet, as shown in Figure 8. 
 

 
 

Figure 8:  Table property sheet for the Member table. 
 

3.  Click the box for the property you want to set. 

 

4.  Type a setting for the property. 

 

If you want more space to enter or edit a property setting, press SHIFT+F2 to display the Zoom 

box.  If you are setting the Validation Rule property to an expression and would like help 

building it, click the Build button to the right of the Validation Rule property box to display the 

Expression Builder. 

 

5.  To save your changes to the table, choose Save from the File menu. 

 

Using Validation Rules for Records 

 

Although you will usually set validation rules for individual fields, you may also want to set a rule 

that applies to a record as a whole.  When you set a validation rule for a table, Microsoft Access 

checks for valid data when you save or leave a record, rather than when you leave a field.  Unlike field 

validation rules, table validation rules can contain references to one or more fields in the table.  This 

makes them useful when you want to compare values in different fields.  For example, you can use a 

table validation rule to ensure that one field's value is always greater than that of another in the same 

record. 

 

You create a table validation rule by setting the table's Validation Rule property to an expression.  

Each time you save a record, Microsoft Access evaluates the expression to make sure it's true. 

 

 

Activity 
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(a) Create a rule that all members must be at least 18 years old when they join the video shop. Set this 

rule as a table property for your Member table (as shown in the Figure 8). Please ensure that you 

understand how the validation expression works by accessing the online help. 

(b) Create a subdatasheet for the Member table to display the video rentals associated with each 

member (as shown in Figure 8).  Save your Member table and examine the table in datasheet 

view.  

 


